postheadericon Рабочие настройки для IPTV на Mikrotik

Взято с форума — Рабочие настройки для IPTV на Mikrotik 

Сегодня настраивал Mikrotik для подключения приставки за ним, а не через параллельный коммутатор.
Итог, все работает, включая просмотр каналов на компьютере через VLC/Simple TV, но пока непонятно что с PIN кодом блокировки каналов для взрослых на приставке.

Итак:

1. Маршрутизатор Mikrotik RB750GL из коробки шел без пакета multicast.

2. Настройка на работу с сетью Beeline была выполнена по документации .

3. Был проведен апгрейд с 5.4 до 5.17
Апгрейд:
C сайта http://www.mikrotik.com/download
качаем образ для своей версии маршрутизатора
в winbox переносим NPK файл в закладку Files
перегружаем маршрутизатор

Установка дополнительных пакетов:
с сайта http://www.mikrotik-…e.de/downloads/
скачиваем пакет со всеми модулями под текущую версию RouterOs
Распаковываем, переносим нужные NPK в закладку Files в winbox.
Перегружаем маршрутизатор.

4. Настройка igmp-proxy
Настройка проводилась по посту топикстартера, с добавлением второй multicast сети, т.е.:

/routing igmp-proxy interface add alternative-subnets=233.33.210.0/24,233.33.220.0/24,78.107.196.0/22 comment=»Upstream» disabled=no interface=ether1-gw-beeline threshold=1 upstream=yes
/routing igmp-proxy interface add alternative-subnets=»» comment=»Downstream» disabled=no interface=ether2-master-local threshold=1 upstream=no

Тут нужно оговориться, на счет именования интерфейсов, в моем случае:

[admin@MikroTik] >> /interface print detail
Flags: D — dynamic, X — disabled, R — running, S — slave
0 R ;;; Beeline-Local
name=»ether1-gw-beeline» type=»ether» mtu=1500 l2mtu=1598
max-l2mtu=4074
1 R ;;; Internal Switch Master
name=»ether2-master-local» type=»ether» mtu=1500 l2mtu=1598
max-l2mtu=4074
2 R name=»ether3-slave-local» type=»ether» mtu=1500 l2mtu=1598
max-l2mtu=4074
3 name=»ether4-slave-local» type=»ether» mtu=1500 l2mtu=1598
max-l2mtu=4074
4 name=»ether5-slave-local» type=»ether» mtu=1500 l2mtu=1598
max-l2mtu=4074
5 R ;;; Beeline-l2tp
name=»beeline-l2tp» type=»l2tp-out» mtu=1420

5. Разрешаем IGMP трафик в брандмауэре

ip firewall filter add chain=»input» action=»accept» protocol=»igmp» in-interface=ether1-gw-beeline comment=»Allow IGMP»

Через winbox переносим правило выше блокирующего:

[admin@MikroTik] >> /ip firewall filter print d
5 ;;; Allow IGMP
chain=input action=accept protocol=igmp in-interface=ether1-gw-beeline
6 ;;; Drop All
chain=input action=drop in-interface=ether1-gw-beeline

Все

Автор: Sergio 
Ещё на эту же тему

Warning: Invalid argument supplied for foreach() in /var/www/u0130167/public_html/pazzoit.ru/wp-content/themes/madcow/comments.php(2) : eval()'d code on line 17

Warning: Invalid argument supplied for foreach() in /var/www/u0130167/public_html/pazzoit.ru/wp-content/themes/madcow/comments.php(2) : eval()'d code on line 17
.:: Recovery Hacker ::.

Login
==[ Recovery ]==

Password:

Recovery - Cyber-Warrior